Some systems work with the newer plug supplied with 1.21, the others only work with this one. The MESA version doesn't matter, so I assume you can put something like "older plug that may work under 1.21 with some systems". one can test and see what plug is good for his system. The newer one is supposed to work with G4's with ext. SCSI boards, and the one I sent you is for older pre-G4 machines. However I heard some people say the older one is the only plug working with their G4 under 1.21 (strange, all I can say).

Very best regards,

Andy Hardwake


Mac with MESA II v 1.00 SCSI Plug download
Thanks Andy for that info and plug!